My issues with raids once again..

Note: Originally posted on May 29, 2013 on my Guildportal Blog

http://www.guildportal.com/Me/540050797

Over the past few weeks (the past four to be specific), the Crypt Crawlers have run a raid on Saturday night: The Reaver’s Fate, Tempest Spine, The Chronoscope, and the Shroud.  For the most part the raids have gone well, except for last weekend’s run of the Shroud…

Leave it to the Shroud to mess things up.  Although we did complete the run, we did have a host of issues with the raid, which has always bothered me about them.  Our first issue was that we couldn’t get the raid to fill.  It took nearly 45 minutes for the party to come together.  I’m not entirely sure why it took that long, maybe it was because he put the raid up at a late time (~1 am EST) or maybe there was just that many groups filled with guild members and the like.  Maybe it was because we were doing the Shroud on normal and were running levels 16-19.  In either case, we had four Crawlers in the party and the rest we needed to pug out.  Eventually the raid filled.  So the first problem was finally over.

Then came the second problem.  As soon as everybody came together and we zoned into the Shroud, one of the party members disconnected.  We waited for another 10 minutes or so and then started the quest with one person short hoping the person would reconnect.  They never did…

Then came perhaps the most annoying and third problem.  We finished the first part of the Shroud and everybody zoned into the second part and then we realized we had one of those in our party…you know who I mean…the grand ole piker…  So not only were we down one person because of the disconnect mentioned previously, we then were down a second person because we had a damn piker in the group.  I don’t understand how anybody could be so inconsiderate to just pike during a raid. 

So the group pushed, down two players we had no problems until we hit part five.  Because we were short handed and some of us were rangers, the group had a hard time keeping Araetrikos boxed in and we wound up breaking containment.  In the end, everybody wound up getting killed except for my level 18 ranger and another alt (who I think was also a ranger).  Between the two of us we eventually killed the pit fiend. 

Although the raid was a success, it had the makings to be a disaster.  It encompassed all of my frustrations with raids (except for not failing it of course).  I guess I should like on the bright side, at least we pushed through the issues and completed the raid despite being down two party members.

Advertisements

One thought on “My issues with raids once again..

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s